Information Regarding Online Vulnerability Known as "Heartbleed Bug"


Apr 21, 2014 -  You may have heard news of an online username and password vulnerability bug, otherwise known as the ‘Heartbleed Bug’, which has affected popular websites that use open-source software, called OpenSSL.

Ledyard is pleased to reassure you that we do not use a vulnerable version of that software, and our encryption continues to be safe and secure. As always, thank you for banking with us.


View the latest Ledyard news